Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System] - Issues with loading the app
Incident Report for Staffbase
Postmortem

Now that our investigation of the incident is complete, we would like to share more detailed information on what happened.

Summary

On December 2, 2024, apps on the German server were temporarily unavailable due to an issue with accessing the database. The first disruption occurred at 08:00 am (CET) and was resolved by 08:20 am (CET). A similar issue reoccurred at 10:00 am (CET) and was fully resolved by 10:20 am (CET) after further adjustments.

What Happened

The system experienced difficulties connecting to the database, which caused interruptions in the backend. This made it impossible for users to access their intranet or app. Immediate actions were taken to increase resources and restore the connection, resolving the issue.

Impact

From 08:00 to 08:20 and again from 10:00 to 10:20, users on the German server were unable to access their intranet or app.

Future Improvements

We will introduce additional checks to ensure the system works and optimise the alerting process to prevent similar issues. Thank you for your patience and understanding while we work to improve our services. If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Dec 06, 2024 - 16:12 CET

Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Dec 03, 2024 - 09:24 CET
Monitoring
After our teams have implemented a solution, we are seeing improvements and the app should be fully available again. We will continue to monitor the situation and will keep you updated shortly.
Posted Dec 02, 2024 - 11:03 CET
Investigating
You may experience slow loading times for the app.

Our teams are currently investigating this issue. We will keep you updated on the progress as we learn more.

We apologize for the interruption. In case you have any questions about this topic, please let us know at support@staffbase.com.
Posted Dec 02, 2024 - 10:11 CET
Monitoring
We have implemented a fix to resolve the issue and the application should now be working as normal. We will continue to monitor the system until the problem has been completely resolved.
Posted Dec 02, 2024 - 08:38 CET
Investigating
Affected feature: App isn't loading or is loading slowly

We have received reports of some customers that the app isn't loading or is loading very slowly and started investigating the issue. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for any inconvenience that may be caused. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Dec 02, 2024 - 08:24 CET
This incident affected: Employee App & Front Door Intranet (Web Application (Germany) [SLA], Native App - iOS, Native App - Android).