Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Long Loading times on our German System

Incident Report for Staffbase

Postmortem

Summary:

Our investigation of the incident is now complete, and we would like to share more details about the issue that occurred between March 11, 10:40 CET, and March 12, 13:47 CET.

What happened:

System checks for certain features caused the backend to slow down.

Impact:

During the mentioned period, users on the German server experienced longer loading times when accessing app or intranet.

Future Improvements:

We have optimized backend metric queries for auto-scaling and reduced the number of system checks. Additionally, we have implemented extra tests to prevent similar issues in the future.

Please contact us at support@staffbase.com if you have any further questions regarding this topic or if any feature is still impacted against our expectations.

Posted Mar 18, 2025 - 14:45 CET

Resolved

This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Mar 12, 2025 - 13:47 CET

Monitoring

Performance has stabilized. We will continue to monitor the situation and update you shortly.
Posted Mar 12, 2025 - 09:43 CET

Investigating

Some customers on our German system may be experiencing slower loading times. Our teams are actively investigating the issue. We will provide updates as soon as we have more information.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Mar 12, 2025 - 08:12 CET

Monitoring

We have made backend adjustments to resolve this issue. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Mar 11, 2025 - 14:06 CET

Investigating

Some customers on our German system may be experiencing slower loading times. Our teams are actively investigating the issue. We will provide updates as soon as we have more information.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the interruption. In case you have any questions about this topic, please let us know at support@staffbase.com.
Posted Mar 11, 2025 - 11:06 CET
This incident affected: App, Intranet & Staffbase Email (Core API (Europe) [SLA]).