Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - [Intermittent Saving issues]
Incident Report for Staffbase
Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Mar 04, 2024 - 21:21 CET
Investigating
Affected feature: Email Designer

It appears as though there is an error with email drafts, where attempting to save may result in an error or a page timeout.

The issue appears to be related to the page updating to show the save having taken place. The drafts appear to be saving correctly when the page is refreshed, and the issue appears to be with the saving icon displaying that the draft has in fact saved.

Our devs are currently working towards a fix for this error. If you have any questions, please feel free to reach out to support@staffbase.com
Posted Mar 04, 2024 - 20:43 CET