Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German datacenter
Incident Report for Staffbase
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 21, 2020 - 14:14 UTC
Investigating
We are currently experiencing a service disruption in the German media center. Mediafiles (images, videos, attachments) might load slowly or not at all at the moment.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Dec 16, 2020 - 17:20 UTC
This incident affected: Infrastructure (Germany) (Media API (Germany)).