Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - [Issues with Web App sending domain]

Incident Report for Staffbase

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 17:52 CEST

Identified

Affected feature: Web App Sending domain

Customers may be experiencing an issue with sending from the Web App. The issue appears to be due to capitalizations in emails and verified domains.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 21, 2023 - 16:50 CEST