Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Delay in email delivery
Incident Report for Staffbase
Resolved
This incident has been resolved by our provider.
Posted Apr 29, 2021 - 14:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 11:57 UTC
Investigating
We are working with our provider to identify the root cause. We will post additional updates as soon as possible.
Posted Apr 29, 2021 - 11:36 UTC
This incident affected: Notification Services (Mail Services).