Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Scheduled Staffbase Email Maintenance

Scheduled for Feb 22, 11:00 - 14:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 19, 2025 - 16:25 CET

Scheduled

We will be undergoing scheduled maintenance on the Staffbase Email Database (EU Server only) on Saturday, February 22nd at 11:00 CET. We ask customers to not schedule or edit drafts draft during this timeframe.

Please feel free to reach out to support@staffbase.com for any further questions
Posted Feb 19, 2025 - 16:25 CET
This scheduled maintenance affects: Employee Email (Classic) (Web Application (Germany) [SLA], Create Service (Germany) [SLA]).