Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Employee Email (Classic) Scheduled Maintenance (EU Server)

Scheduled for Apr 5, 10:00 - 12:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted 5 days ago. Mar 24, 2025 - 16:08 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted 5 days ago. Mar 24, 2025 - 15:55 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted 5 days ago. Mar 24, 2025 - 15:53 CET

Scheduled

We will be undergoing scheduled maintenance on Saturday, April 5th at 10:00 CET (4:00 am EST). The scheduled maintenance will impact Employee Email classic customers on our EU server only. We ask customers to not schedule or edit drafts during this timeframe.
Posted 5 days ago. Mar 24, 2025 - 15:33 CET
This scheduled maintenance affects: Employee Email (Classic) (Web Application (Germany) [SLA], Create Service (Germany) [SLA]).