Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet/Email] [Global] - Degraded Performance of AI Navigator, Podcast Generation and other AI parts of Staffbase

Incident Report for Staffbase

Resolved

This incident has been resolved. The Navigator and other affected AI features are fully functional again. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Aug 31, 2026 - 14:09 CEST

Monitoring

We have taken measures to resolve the issue and restore the full functionality of all AI tools/parts within Staffbase. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Aug 31, 2026 - 12:18 CEST

Investigating

Affected feature: Staffbase AI (Navigator, Podcast, Email/Page generation)

Some customers may be experiencing trouble with our AI tools and encountering error messages when interacting with them.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support team at support@staffbase.com.
Posted Aug 31, 2026 - 11:57 CEST
This incident affected: App/Intranet/Email (Common Features).