Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - [Loading errors when editing and creating Email Drafts/Template]
Incident Report for Staffbase
Resolved
Our team have identified the issue and this incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jan 05, 2024 - 05:15 CET
Investigating
Affected feature: Email Draft/Template editing and creating

Some users may be experiencing issues with loading Email Drafts/Templates. It appears to be intermittent and the draft can be loaded after refreshing the page.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Jan 04, 2024 - 23:01 CET
This incident affected: Employee Email (all regions) (Web Application (US) [SLA], Web Application (Germany) [SLA]).