Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Feature disruption: Channel & Page Settings
Incident Report for Staffbase
Resolved
This incident has been completely resolved. Admins are now able to attach channels to a newspage. Please make sure to disable browser cache / delete the browser cache in case you still experience any troubles.

If you have any questions or feedback, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Mar 26, 2020 - 15:14 CET
Update
We are continuing to monitor for any further issues.
Admins can now edit the visibility settings and access the settings overview for pages, but are not able to attach channels to a newspage yet.

The workaround mentioned below is still applicable and can be used.

Our team is urgently working on a fix and we will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Mar 25, 2020 - 19:45 CET
Update
We are continuing to monitor for any further issues.
Admins can now edit the visibility settings and access the settings overview for pages, but are not able to attach channels to a newspage yet.

Our team is urgently working on a fix and we will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Mar 25, 2020 - 17:51 CET
Monitoring
A fix has been implemented, and we are monitoring the issue. If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Mar 25, 2020 - 17:08 CET
Identified
We are currently experiencing a feature disruption for channel and page settings in the admin panel. Admins are not able to attach channels to a newspage, edit the visibility settings and access the settings overview for pages.
Currently, a workaround would be to add the admin who needs to change content as "Space Administrator" - this will give access to the settings.

Our team is urgently working on a fix and we will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Mar 25, 2020 - 12:40 CET