Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet/Email] [Global] - error loading contents

Incident Report for Staffbase

Monitoring

Update: We have deployed a fix for the issue. Functionality has been restored, and we are now monitoring all environments to confirm.

We will post a final update once monitoring confirms full stability.
Posted Jul 14, 2026 - 16:54 CEST

Investigating

Some users may encounter an issue where forms, pages, or other content fail to load and instead display the error message "error.unknown.title".

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Jul 14, 2026 - 16:10 CEST
This incident affects: App/Intranet/Email (Web App (Americas) [SLA], Web App (Europe) [SLA], Web App (Asia/Pacific) [SLA], Test Application / Stage Environment).