The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Oct 03, 2024 - 00:21 CEST
Monitoring
Our teams are seeing improvements to the system, and believe customers should be able to send emails without issue again. We will continue to monitor the situation and update you shortly. Please let support@staffbase know if you are still having issues.
Posted Oct 02, 2024 - 19:09 CEST
Investigating
Affected feature: Staffbase Email
Some customers may be experiencing issues sending and receiving emails.
Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.
We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Oct 02, 2024 - 16:28 CEST
This incident affected: Employee Email (Classic) (Web Application (US) [SLA]).