Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - Delay in Email Delivery
Incident Report for Staffbase
Resolved
We have confirmed the issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Nov 22, 2024 - 19:37 CET
Monitoring
We believe that email sending has returned to normal and the issue has been resolved. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Nov 22, 2024 - 17:50 CET
Investigating
Affected feature: Email

Customers may be experiencing a delay in emails being delivered when sent from the web-app

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Nov 22, 2024 - 17:30 CET
This incident affected: Employee Email (Web Application (US) [SLA]).