The system is now operating normally again, and services are fully available. We will continue to monitor performance closely over the coming period to ensure ongoing stability and will provide further updates.
Posted Feb 20, 2026 - 16:47 CET
Investigating
We are currently experiencing partial outages in the system again and are actively investigating the cause. Our team is working to restore normal operations as quickly as possible and will provide updates as soon as more information becomes available.
Posted Feb 20, 2026 - 15:33 CET
Monitoring
We have implemented measures to address the issue, and the affected products are available again. Our team continues to monitor the situation closely.
Posted Feb 20, 2026 - 14:52 CET
Identified
We’ve identified the issue and are seeing slight improvements with the affected products becoming available again. Our team is still actively investigating and we will provide further updates as soon as more information becomes available.
Posted Feb 20, 2026 - 14:23 CET
Update
We are continuing to investigate this issue.
Posted Feb 20, 2026 - 13:36 CET
Investigating
Affected feature: App/Intranet & EMail
We are currently experiencing a major disruption on the US system. The App/Intranet and EMail are not accessible at the moment. Our teams are investigating this with the highest priority and are working to restore the service as quickly as possible. We will share further updates soon.
We sincerely apologize for the inconvenience. If you have any urgent questions, please reach out to our support at support@staffbase.com
Posted Feb 20, 2026 - 13:31 CET
This incident affects: App, Intranet & Staffbase Email (Core API (Americas) [SLA], Web Application (Americas) [SLA], Staffbase Email API (Americas), Native App - iOS, Native App - Android).