Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System] - Long loading times

Incident Report for Staffbase

Postmortem

Summary:
Now that our investigation of the incident is complete, we would like to share more details about the issue that occurred on April 22 between 08:45 CET and 10:50 CET.

What happened:
A change to our infrastructure was rolled out which caused an unforeseen delay in requests and slowed our backend down. This alarmed our teams who immediately worked on restoring the performance of our system.

Impact:
During the mentioned timeframe, users on our German system experienced long loading times or unresponsiveness when accessing the app or intranet.

Future Improvements:
We will explore options to introduce additional testing setups to prevent similar issues in the future. Please contact us at support@staffbase.com if you have any further questions or feedback regarding this topic.

Posted Apr 23, 2025 - 16:19 CEST

Resolved

The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Apr 22, 2025 - 12:55 CEST

Monitoring

Our teams are seeing performance metrics being back to normal and customers should no longer experience long loading times. We will continue to monitor the situation and update you shortly.
Posted Apr 22, 2025 - 10:59 CEST

Investigating

Customers hosted on our German System may be experiencing longer loading times.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Apr 22, 2025 - 09:07 CEST
This incident affected: App, Intranet & Staffbase Email (Core API (Europe) [SLA]).