Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System / US System] - Customers reported missing widgets on pages after earlier saving issues

Incident Report for Staffbase

Postmortem

Summary

Between 1:25 PM CET and 5:35 PM CET on June 2, 2025, some customers experienced issues when saving pages. In some cases, saving failed completely, and in others, parts of the page—especially widgets—were unintentionally removed. The issue has been resolved, and we’re taking steps to prevent this from happening again.

What Happened

A backend change was made to improve how we sanitize page content before saving it. This change introduced a new step using an internal service to clean the content. However, the service wasn’t prepared for the additional load and started to fail shortly after the update.

As a result:

  • From 1:25 PM CET to 2:25 PM CET, many users saw errors when trying to save pages.
  • In the next few hours, even if saving appeared successful, certain content blocks (widgets) could have been removed. This included both custom widgets and built-in ones like the MS365 and embedded page widgets.

We identified the root cause and fixed the issue by increasing system capacity.

Actual Impact

  • All customers across all environments could have been affected if they saved content during the impacted window.
  • Saving pages mostly failed between 1:25 PM CET and 2:25 PM CET.
  • In the next few hours, some content on pages (especially widgets) may have been removed upon saving.
  • Page settings or other editor actions not involving a full page save were not affected.

Future Improvements

To prevent this type of issue in the future, we are:

  • Improving how we test backend changes—especially those that affect page content.
  • Strengthening monitoring to catch unusual behavior earlier.
  • Reviewing how we use content sanitization services to make sure they don't unintentionally remove valid content.

We are currently working to identify exactly which pages were affected. If we are able to determine that specific pages were impacted, we will proactively reach out to the affected customers. However, please understand that it may not be possible to identify every affected page with complete certainty.

We sincerely apologize for the disruption and any inconvenience this may have caused. If you believe that any of your page content was affected, please don’t hesitate to contact our support team — we’re here to help.

Posted Jun 05, 2025 - 09:36 CEST

Resolved

This incident has been resolved. We are sorry for the trouble this has caused. We will contact affected customers separately to inform them about the impacted pages.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jun 03, 2025 - 10:26 CEST

Identified

Affected feature: Pages

Customers have reported issues where saving a page leads to custom widgets being removed.

The issue is related to an earlier problem where an error message was displayed and pages couldn’t be saved for a short time. Our development team addressed the issue as soon as they became aware of it, and saving is working again. However, pages saved since 13:30 CEST might miss custom widgets that were previously there. Also, saving a page with certain widgets will remove them from the page. The developers are already looking into that and will release a fix as soon as possible.
Posted Jun 02, 2025 - 16:28 CEST
This incident affected: App, Intranet & Staffbase Email (Common Features).