Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German and US System]The Forms plugin does currently not include the Identifier
Incident Report for Staffbase
Postmortem

Summary
Between December 12, 2024, 1:20 PM CET, and December 13, 2024, 2:45 PM CET, the Forms Plugin on the German and US servers experienced an issue where the Identifier field (External ID) was not displayed correctly. The issue was identified and resolved with a system update.
What Happened
An adjustment in system settings caused the Forms Plugin to stop displaying the Identifier field. After the issue was identified, a system update was rolled out to restore the functionality.
Impact
During the affected timeframe, forms submitted through the Forms Plugin were missing the Identifier field, potentially impacting data completeness. Affected submissions were able to be retrieved upon request.
Future Improvements
We will implement additional checks to ensure all plugin functionalities remain stable during system adjustments and continue improving our processes to prevent such occurrences. Thank you for your understanding and patience as we work to enhance our services. If you have any questions or concerns, please do not hesitate to contact our support team at support@staffbase.com.

Posted Jan 03, 2025 - 16:06 CET

Resolved
The issue has been resolved.
The Forms plugin is now functioning as expected, and identifiers are included in the evaluation of forms again.

Unfortunately, any forms submitted during the incident period (from 12.12.2024 at 13:20 CET to 13.12.2024 at 14:45 CET) will not include the identifier it in their evaluation. We apologize for the inconvenience.

If you have any further questions or encounter any issues, please contact us at support@staffbase.com. We’re happy to assist you!
Posted Dec 13, 2024 - 15:40 CET
Monitoring
We have implemented a fix to resolve the issue and the Identifier should now be included in the evaluation of forms again.
We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Dec 13, 2024 - 14:39 CET
Identified
We have identified the root cause and will now take steps to fix the issue.
Posted Dec 13, 2024 - 14:26 CET
Investigating
Affected feature: App/Intranet

We have received reports that the Forms plugin is currently not including the identifier in the evaluation of forms. This issue is affecting customers on both US and DE servers. Our teams are investigating the behavior and will work to resolve this as fast as we can. We will share more information soon.
You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.
We apologize for the inconvenience this may cause. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com
Posted Dec 13, 2024 - 14:01 CET
This incident affected: Employee App & Front Door Intranet (Common Features).