Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - CSV Distribution lists are not importing and showing as "queued"
Incident Report for Staffbase
Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Dec 15, 2023 - 16:34 CET
Monitoring
We have shutdown the External Contacts API to resolve this issue. The imported CSV Distribution lists will be slowly updated and processed shortly.

We will continue to monitor the contacts upload until our service have returned to normal.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Dec 14, 2023 - 23:07 CET
Identified
Our development team have identified the issue. The external contact API was used and caused a very large number of requests for updating / inserting contacts. Therefore the processing system was failing.

A fix is currently being implemented to resolve external contact API.
Posted Dec 14, 2023 - 22:50 CET
Investigating
There is currently an issue where CSV Distribution lists are not importing and showing as "queued".

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Dec 14, 2023 - 21:13 CET
This incident affected: Employee Email (all regions) (Web Application (US) [SLA]).