Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German infrastructure
Incident Report for Staffbase
Resolved
The issue has been resolved. Performance is back to normal.

We apologize for the inconvenience - please do not hesitate to contact us at support@staffbase.com if you have any questions.
Posted Feb 02, 2021 - 14:05 CET
Investigating
We are currently experiencing a service disruption in the German Core API. The app may be slow or unresponsive
Our team is working to identify the root cause. We will post additional updates as soon as possible.

We apologize for the inconvenience - please do not hesitate to contact us at support@staffbase.com if you have any questions.
Posted Feb 02, 2021 - 12:53 CET
This incident affected: Employee App & Front Door Intranet (Germany) (Core API (Germany) [SLA]).