Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Page version history not working correctly

Incident Report for Staffbase

Resolved

The issue regarding page version history is resolved. Please get in touch with us at support@staffbase.com in case you're still having any problems.
Posted Nov 25, 2025 - 21:51 CET

Monitoring

We have released an update to resolve the issue. Page Version History should be working as intended again We will continue to monitor the systems until we are sure the issue is fully resolved.

If you have any questions, or are still having difficulties, please reach out to our support at support@staffbase.com.
Posted Nov 25, 2025 - 18:49 CET

Investigating

Customers may be experiencing an issue in the App where restoring a page from its version history does not complete as expected. Customers have reported that selecting a version to restore results in no changes being applied.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Nov 25, 2025 - 17:48 CET
This incident affected: App, Intranet & Staffbase Email (Common Features).