Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German & US datacenter
Incident Report for Staffbase
Resolved
The issue has been resolved.
Our developers were able to identify the root cause and have now stabilized the performance of the app again. We can confirm everything is back to normal.

We apologize for the inconvenience. If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Feb 05, 2020 - 14:29 CET
Monitoring
A solution has been implemented and we are closely monitoring the solution. Your application should be reachable again.

We apologize for the inconvenience. If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Feb 05, 2020 - 14:03 CET
Identified
The cause has been identified and we are about to implement a solution.
Posted Feb 05, 2020 - 13:37 CET
Investigating
We are currently experiencing a service disruption in the German and the US datacenter. Your app might be periodically slow or unresponsive.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Feb 05, 2020 - 13:33 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (US) [SLA], Core API (Germany) [SLA], Native App - iOS, Native App - Android).