Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System / US System / Asia/Pacific System] - Incorrect Page Update Timestamps

Incident Report for Staffbase

Postmortem

Summary
As our investigation of the incident is now complete, we would like to share more details about the issue that occurred between February 4th, 5:15 PM CET and February 5th, 5:45 PM CET leading to incorrect update time stamps for some pages.

What happened
In preparation for our February 12th release, a new property was added to the “Update Reminder” feature. While deploying this configuration change, a system process unintentionally triggered a timestamp refresh for all pages where an update reminder was active. This caused the system to treat the configuration change as a content update.

Impact
Between February 4th, 5:15 PM CET and February 5th, 5:45 PM CET, pages with an active update reminder displayed an incorrect timestamp. This reflected the timing of our internal system change rather than actual edits made to the page content. Our developers successfully identified the cause and reverted the timestamps for all impacted pages by February 5th, 5:45 PM CET. No page content was modified or lost during this process.

Future improvements
We will implement additional safety guards that prevent configuration changes from leading the system to interpret them as content changes. Thank you for your patience and understanding while we work to improve our services and prevent future incidents. If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Feb 17, 2026 - 14:17 CET

Resolved

Affected feature: Studio Page Management

Between February 4th, 5:15 PM CET and February 5th, 5:45 PM CET, some users may have noticed incorrect “Updated” timestamps for pages in the Studio. Many pages were erroneously labeled as updated during a specific window on February 4th.

Our engineering team identified the root cause and has restored the timestamps to reflect the actual last content change. As of 5:45 PM CET today, all timestamps have been corrected. No action is required from users.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Feb 05, 2026 - 18:00 CET