Do you have questions about performance or outages? Our friendly Customer Care team can help! Get in touch
Write-up published
Resolved
SummaryAs our investigation of the incident is complete, we would like to provide you with more detailed information about the incident that occurred on November 4 between 09:30 AM and 10:45 AM \(CET\). This prevented users from logging in via SSO into their Employee App & Front Door Intranet hosted on the German system.
What happenedA version update of the SSO microservice led to an increased collection of SSO metrics and overwhelmed the storage. This resulted in an out-of-memory error, causing the microservice to crash. Increasing the available memory and rolling back the SSO microservice to the previous stable version allowed SSO to work again.
ImpactBetween 09:30 AM and 11:00 AM \(CET\), our customers reported issues when logging in via SSO into their Employee App & Front Door Intranet hosted on the German system. Users relying on SSO received a “no healthy upstream” error and were unable to access their environment.
Future improvementsWe will implement additional checks and alerts for the SSO microservice. Thank you for your patience and understanding while we work to improve our services and prevent future incidents. If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Identified
We have identified the root cause and will now take steps to reenable the SSO login for all customers on the German system. We will update you as soon as the necessary changes take place.
To check which system your application is hosted on, go to Studio > Settings > API Access and review the tag next to the title.