Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Degraded performance/Slow responses of our App
Incident Report for Staffbase
Resolved
Our provider Microsoft Azure implemented a fix, so we can confirm that all apps are working as intended again. We are sorry for the inconvenience this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jan 25, 2023 - 12:56 CET
Update
We have identified the root cause. It seems that Microsoft Azure (being used as hosting provider for our applications and services) is facing multiple outages across all regions, which is causing degradation of all services. Microsoft is working on restoring the availability. Until then, the Staffbase services might be interrupted. For more information, check: https://status.azure.com/de-de/status
We will keep you updated as we learn more.
Posted Jan 25, 2023 - 10:02 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 25, 2023 - 09:53 CET
Identified
We have identified the root cause. It seems that Microsoft Azure (being used as hosting provider for our applications and services) is facing multiple outages across all regions, which is causing degradation of all services. Microsoft is working on restoring the availability. Until then, the Staffbase services might be interrupted. For more information, check: https://status.azure.com/de-de/status
We will keep you updated as we learn more.
Posted Jan 25, 2023 - 09:43 CET
Investigating
Some customers may experience slow loading times. Our teams are investigating right now. We will update you as we learn more.
Posted Jan 25, 2023 - 08:58 CET
This incident affected: Employee Email (Germany) (App Services (Germany), Web Application (Germany) [SLA], Event System (Germany), Create Service (Germany) [SLA]), Employee Email (US) (App Services (US), Web Application (US) [SLA], Event System (US), Create Service (US) [SLA], Client Integrations (US) [SLA]), Employee App & Front Door Intranet (US) (Web Application (US) [SLA]), Employee App & Front Door Intranet (Germany) (Web Application (Germany) [SLA]), and Employee App & Front Door Intranet (Global / Common Services) (Native App - iOS, Native App - Android, Test Application / Stage Environment).