Delay in email delivery
Incident Report for Staffbase
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted 3 months ago. Apr 18, 2019 - 11:04 UTC
Investigating
We are currently experiencing a delay for emails being sent from our system (notifications, invitations, updates). Our team is working to identify the root cause. We will post additional updates as soon as possible.

Please feel free to reach out to us via support@staffbase.com if you need further guidance or have questions concerning this issue. We apologize for the inconvenience and thank you for your patience.
Posted 3 months ago. Apr 18, 2019 - 07:33 UTC
This incident affected: Common Services (Plugins, Push Notifications...) (Mail Services).