Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Loading issues with the analytics
Incident Report for Staffbase
Resolved
Our team was able to find and fix the cause quickly - the incident is now resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jan 20, 2022 - 09:36 CET
Investigating
Some customers may be experiencing loading issues with the analytics.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Jan 20, 2022 - 09:01 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (Germany) [SLA]).