Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German datacenter (NO CDN)
Incident Report for Staffbase
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Feb 14, 2018 - 17:40 CET
Monitoring
A solution has been implemented and we are monitoring the system actively. Images should load again like expected. If you see any unusual behaviour please report it to support@staffbase.com
Posted Feb 14, 2018 - 17:12 CET
Investigating
We are currently experiencing a service disruption in the German datacenter. Images might not load if your app is hosted on the german datacenter and CDN is turned off.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Feb 14, 2018 - 17:04 CET