Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the US datacenter
Incident Report for Staffbase
Resolved
The issue has been resolved. We attempt to still send out missed notifications as possible. We apologize for the inconvenience.
Posted Aug 30, 2018 - 22:50 CEST
Investigating
We are currently experiencing an outage in our US datacenter. Push messages and email notifications are currently not working for the clients hosted on our US system.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Aug 30, 2018 - 21:34 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (US) [SLA]).