Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption - push notification
Incident Report for Staffbase
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Jun 23, 2021 - 08:58 CEST
Monitoring
We have released an update to resolve the issue and push messages should be slowly working again. Push messages will be sent out delayed over the next hours.

We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Jun 22, 2021 - 21:44 CEST
Investigating
We are currently experiencing an inconsistency on our European push server which can lead to unprocessed push notifications and email send-outs.
Posted Jun 22, 2021 - 17:00 CEST