Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Infrastructure Updates: Test System
Scheduled for Jun 16, 07:30 - 13:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 16, 2021 - 06:45 UTC
Scheduled
Due to infrastructure improvements, we will be performing scheduled maintenance on our testing system on June 16 - 7.30 UTC / 9.30 CET.

Both the web applications and native apps may be unavailable during the time of this update. We will do our best to minimize the impact.

The maintenance will not have any impact on live applications (hosted on the International & German system).

Please report any unusual behavior to support@staffbase.com and we will be happy to assist you.
Posted Jun 14, 2021 - 06:45 UTC
This scheduled maintenance affects: Common Services (Plugins, Push Notifications...) (Common Features).