Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption: Analytics
Incident Report for Staffbase
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 09, 2020 - 16:20 UTC
Investigating
We are currently experiencing a service disruption with the Analytics feature on both systems (Germany & US). Analytics might not show up for today or might be slower than usual.

Our team is working to identify the root cause. We will post additional updates as soon as possible.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Dec 09, 2020 - 15:52 UTC
This incident affected: Common Services (Plugins, Push Notifications...) (Common Features).