Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German data center (media files)
Incident Report for Staffbase
Resolved
The issue has been resolved.

Please feel free to reach out to us via support@staffbase.com if you need further guidance or have questions concerning this issue. We apologize for the inconvenience and thank you for your patience.
Posted May 02, 2019 - 10:36 CEST
Update
We are continuing to work on a fix for this issue. The issue should be gone for new uploads but some older images might be still unreachable right now.
Posted May 02, 2019 - 09:53 CEST
Identified
We are currently experiencing a service disruption in the German data center. Your media files might be loading periodically slow or might be unreachable.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted May 02, 2019 - 09:33 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Media API (Germany) [SLA]).