Service disruption: www.staffbase.com
Incident Report for Staffbase
Resolved
The website is back up.
Posted about 1 year ago. Mar 20, 2018 - 13:51 UTC
Investigating
We are currently experiencing a service disruption for our website www.staffbase.com

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted about 1 year ago. Mar 20, 2018 - 13:21 UTC